<!doctype html>
<html class="no-js no-webp theme-enhanced theme-custom theme-bold" lang=en>
<head>
<title>Pisces Horoscope For Thursday, November 11, 2021</title>
<meta name=description content="Today's Pisces horoscope • Daily Pisces horoscope for Thursday, November 11, 2021. Whats in store for zodiac sign Pisces Today?">
<link rel=manifest href="https://s0.nxstatic.com/static/astrology/horoscope/assets/data/manifest.json?_=b2fc546">
<link rel=alternate type="application/rss+xml" title="Pisces Daily Horoscope for Thursday, November 11, 2021 &raquo; Feed" href="https://feeds.feedburner.com/TodaysPiscesHoroscope">
<meta name=theme-color content="#8e24aa">
<meta charset=utf-8>
<meta property=fb:app_id content=121476094536573>
<meta name=viewport content="width=device-width, minimum-scale=1, initial-scale=1.0, shrink-to-fit=no">
<link rel=dns-prefetch href="https://s0.nxstatic.com">
<link rel=preconnect href="https://s0.nxstatic.com" crossorigin>
<link rel=dns-prefetch href="https://files.prokerala.com">
<link rel=dns-prefetch href="https://www.google-analytics.com">
<link rel=preconnect href="https://www.google-analytics.com">
<link rel=dns-prefetch href="https://stats.g.doubleclick.net">
<link rel=dns-prefetch href="https://www.google.com">
<link rel=dns-prefetch href="https://pagead2.googlesyndication.com">
<link rel=dns-prefetch href="https://partner.googleadservices.com">
<link rel=dns-prefetch href="https://tpc.googlesyndication.com">
<link rel=dns-prefetch href="https://googleads.g.doubleclick.net">
<link rel=dns-prefetch href="https://securepubads.g.doubleclick.net">
<link rel=dns-prefetch href="https://adservice.google.com">
<link rel=dns-prefetch href="https://www.googletagservices.com">
<link rel=dns-prefetch href="https://sb.scorecardresearch.com">
<link rel=dns-prefetch href="https://static.clmbtech.com">
<link rel=dns-prefetch href="https://c.go-mpulse.net">
<link rel=canonical href="https://www.prokerala.com/astrology/horoscope/?sign=pisces">
<link rel=amphtml href="https://www.prokerala.com/astrology/horoscope/?sign=pisces&amp;amp=1">
<link rel=icon sizes=any type="image/svg+xml" href="/favicon.svg">
<link rel="alternate icon" href="/favicon.png">
<link rel=apple-touch-icon href="https://s0.nxstatic.com/apple-touch-icon.png">
<style>
enx-image:not(:defined)[aspect="2"] img{position: absolute;top: 0}
enx-image:not(:defined)[aspect="2"]{padding-bottom: 50%;}
enx-image:not(:defined)[aspect="1"] img{position: absolute;top: 0}
enx-image:not(:defined)[aspect="1"]{padding-bottom: 100%;}
enx-image:not(:defined)[aspect="1.5"] img{position: absolute;top: 0}
enx-image:not(:defined)[aspect="1.5"]{padding-bottom: 66.667%;}
enx-image:defined[aspect]{padding-bottom: unset}
</style>
<noscript><style>enx-image > noscript + * {display: none}</style></noscript>
<style id=page-critical-css>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</style>
<noscript><link rel=stylesheet href="/static/theme/unity/assets/css/style.min.css?_=6bb3c238" id=theme-stylesheet crossorigin></noscript>
<link href="https://www.prokerala.com/static/theme/unity/assets/css/style.min.css?_=6bb3c238" rel=preload as=style onload="(this.rel!=='stylesheet') && (this.rel='stylesheet'); (_DRCB||[]).push(['$.trigger','stylesheet.load', 0]);" id=theme-stylesheet crossorigin data-critical>
<noscript><link rel=stylesheet href="/static/astrology/horoscope/assets/css/unity.min.css?_=22818386" crossorigin></noscript>
<link href="https://www.prokerala.com/static/astrology/horoscope/assets/css/unity.min.css?_=22818386" rel=preload as=style onload="(this.rel!=='stylesheet') && (this.rel='stylesheet'); (_DRCB||[]).push(['$.trigger','stylesheet.load', 1]);" crossorigin data-critical>
<style>:root{--theme-bg-primary:#8e24aa;--theme-color-primary:#fff;--theme-bg-secondary:#4a148c;--theme-color-secondary:#fff}</style>
<style>.sample-prediction-list>li{list-style-type:none}.sample-prediction-list>li>.t-xlarge{line-height:1.8em}.sample-prediction-list>div{position:relative}.sample-prediction-sign{margin-top:8px;font-size:20px}.sample-prediction-sign>a:before{content:" ";position:absolute;width:100%;height:100%;left:0}.nav-icon-bar{text-transform:none}.nav-icon-bar>.active,.nav-icon-bar>.active:hover{background:#ffc107;position:relative;font-weight:700}.nav-icon-bar>.active:after{content:"";position:absolute;bottom:-5px;left:36%;width:0;height:0;border-top:10px solid #ffc107;border-left:10px solid transparent;border-right:10px solid transparent}</style>
<style>.astrology-wdgt-slider-cards-wrapper{text-align:center;overflow:auto hidden}.astrology-wdgt-slider-cards{min-width:980px}.astrology-wdgt-slider-cards>div{margin-bottom:.75rem}.astrology-wdgt-slider-cards>div>a{padding:0 .75rem;display:block}.astrology-wdgt-slider-img{border-radius:50%;overflow:hidden}.astrology-wdgt-slider-cards>div>a>.caption{margin:.5rem -.75rem 0;font-size:.7em;line-height:1.2em;color:#000;display:block}@media (min-width:1000px){.astrology-wdgt-slider-cards-wrapper{overflow:hidden}}</style>
<script>var CDN_BASE_URL = "https://s0.nxstatic.com",
                    _DRCB = [],
                    PAGE_TARGETING = {"is_amp":false,"page_type":"webpage"},
                    REQ_START = new Date,
                    REQ_METHOD = "GET",
                    THEME_NAME = "Unity",
                    REQUEST_SECTION = "horoscope";

                var SREC_SAMPLE_RATE = document.location.pathname.match(/^[\/]*(?:astrology|festivals|(?:general\/+)?calendar|numerology|downloads\/+name-ringtones)/) ? 0.2 : undefined;</script>
<script>"use strict";window.console=window.console||{};var BROWSER_GRADE=1;!function(e,n){function t(){var n=arguments;return t.data.push([n,new Date]),t.old?t.old.apply(e,n):null}t.data=[],t.old=e.onerror,
e.onerror=t,e.preInitErrorHandler=t,e.$=function(e,n){return(n||document).querySelector(e)},e.$$=function(e,t){return n.slice.call((t||document).querySelectorAll(e))},e.loadScript$=function(e,n,t,o){
var r=document.createElement("script"),a=document.getElementsByTagName("script")[0];return r.src=e,n&&(r.onload=n),t&&(r.onerror=t),r.async=!o,a.parentNode.insertBefore(r,a),r};var o={};function r(e){
var n;return o[e]=o[e]||[new Promise((function(e){return n=e})),n]}$.when=function(e){return r(e)[0]},$.done=function(e,n){r(e)[1](n)};var a=document.createElement("div");$.trigger=function(e,n){
return a.dispatchEvent(new CustomEvent(e,{detail:n}))},$.on=a.addEventListener.bind(a),$.off=a.removeEventListener.bind(a);var c=function(e){return e.b$=e.b$||{}};$.data=function(e,n,t){
return t?c(e)[n]=t:c(e)[n]},$.parse=function(e){var t=document.createElement("div");return t.innerHTML=e,n.slice.call(t.children)}}(window,[]),function(e,n,t,o){var r;function a(n){e[n]=function(){
_AmdList.push([n,arguments])}}e.noop=function(){},r=t.error||noop,t.error=function(n){var o=arguments;n instanceof Error&&(o=[n.message||n.description,n.fileName,n.lineNumber,n.columnNumber,n]),
r.apply(t,o),onerror.apply(e,o)},e._AmdList=[],a("require"),a("define"),function(){var t=!1;try{t=!!n.createEvent("TouchEvent")}catch(e){}
var o=navigator.userAgent.match(/Mobile|Tablet/)?" device-handheld":"";function r(e){n.documentElement.className=n.documentElement.className.replace(new RegExp("no-"+e),e)}o+=t?" touch":" no-touch",
o+=" theme-is-loading",n.documentElement.className+=o,r("js");var a=new Image
;a.src="data:image/webp;base64,UklGRkoAAABXRUJQVlA4WAoAAAAQAAAAAAAAAAAAQUxQSAwAAAARBxAR/Q9ERP8DAABWUDggGAAAABQBAJ0BKgEAAQAAAP4AAA3AAP7mtQAAAA==",a.onload=function(){a.width&&a.height&&r("webp")},
e.fetch&&Object.assign?$.done("$.ready"):loadScript$("https://www.prokerala.com/static/theme/unity/assets/js/polyfill.min.js?_=4671676e",!1,!1,!0)}(),e.google_analytics_uacct="UA-1458794-1";var c=e._gaq||[];function i(n){
for(var t=0,o=c.length;t<o;t++)c[t][0]===n&&u.apply(e,c[t][1])}function u(){dataLayer.push(arguments)}i(0),e.dataLayer=e.dataLayer||[],u("js",new Date),i(1),u("set","dimension5","Unity"),
"page_type"in e.PAGE_TARGETING&&u("set","dimension9",e.PAGE_TARGETING.page_type),u("config","UA-1458794-1"),u("config","G-MCXTT07C9Q"),
loadScript$("https://www.googletagmanager.com/gtag/js?id=G-MCXTT07C9Q"),i(2)}(window,document,console);var SESS_PAGE_COUNT=parseInt((document.cookie.match(/_PAdC=(\d+)/)||[0,0])[1])+1
;document.cookie="_PAdC="+SESS_PAGE_COUNT+"; path=/";
//# sourceMappingURL= https://sourcemap.prokerala.com/theme/unity/assets/js/head-content.min.js.map?_=9e4ff7b1</script>
<script>"use strict";_DRCB.push((function(){var e=document.documentElement,t=function(){var t=$("#page-critical-css");e.classList.remove("theme-is-loading"),t&&t.parentNode.removeChild(t)};function l(){
$$('link[rel="preload"][as="style"]').forEach((function(e){e.rel="stylesheet"}))}!function(){$.on("stylesheet.load",(function(){
0===$$("link[data-critical][rel=preload]").length&&$.done("theme-stylesheet.load")})),$.when("theme-stylesheet.load").then(t);var e=!1;try{e=document.createElement("link").relList.supports("preload")
}catch(e){}e||l(),window.addEventListener("load",(function(){$.done("theme-stylesheet.load"),l()}))}()}));
//# sourceMappingURL= https://sourcemap.prokerala.com/theme/unity/assets/js/css-load-handler.min.js.map?_=3823b936
;</script>
<script>var gptUnits=[]</script>
<link rel=preload href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as=script>
<script>"use strict";!function(){function n(n,t,e,i){var o;(o=n.querySelectorAll("[".concat(t,"]")),Array.prototype.slice.call(o,0)).forEach((function(n){var o=n;o.setAttribute(e,o.getAttribute(t)),
i?o[t]=i:o.removeAttribute(t)}))}function t(){var n=this;"IntersectionObserver"in window&&(this.io=new IntersectionObserver((function(t){t.forEach((function(t){
t.intersectionRatio>0&&(n.io.unobserve(t.target),n.load(t.target))}))}),{rootMargin:"50px 0px",threshold:.01}))}t.prototype.add=function(n,t){this.io&&!function(n){
return-1===n.src.indexOf("enx-image-placeholder")&&n.complete&&n.naturalWidth}(t)&&"lazy"===t.getAttribute("loading")&&(this.io.observe(n),n.classList.add("enx-image-loading"))},
t.prototype.transform=function(n){var t=n.querySelector("img");this.add(n,t)},t.prototype.load=function(t){var e=t.cloneNode(!0).querySelector("img");e.onload=function(){n(t,"data-srcset","srcset"),
n(t,"data-sizes","sizes"),n(t,"data-src","src"),t.classList.remove("enx-image-loading")},e.removeAttribute("loading")},window.ImgLazy=t,_DRCB.push((function(){var n=new t
;$$("enx-image").forEach((function(t){try{n.transform(t)}catch(n){console.error("[ImgLazy] ",n.message)}}))}));var e=new t,i=document.createElement("template");function o(){
var n="Reflect"in window&&"construct"in Reflect?Reflect.construct(HTMLElement,[],o):HTMLElement.apply(this,[]),t=n.attachShadow({mode:"open"});return t.appendChild(i.content.cloneNode(!0)),
t.querySelector("slot").addEventListener("slotchange",a.bind(n,n)),n.aspect=1,n.layout="fixed",n.defaultAspect=1,n.wrapper=t.querySelector(".wrapper"),e.transform(n),n}function s(){
var n=(100/("responsive"===this.layout?this.aspect||this.defaultAspect:0)).toFixed(3);this.wrapper.style.paddingBottom="".concat(n,"%")}function a(n){var t=n,i=t.querySelector("img")
;i?(t.defaultAspect=parseInt(i.width,10)/parseInt(i.height,10)||1,s.call(t)):e.transform(t)}
i.innerHTML='\n    <style>\n    .wrapper::before {\n        display: block;\n        line-height: 0;\n    }\n    :host {\n        display: inline-block;\n    }\n    :host([layout="responsive"]) {\n        display: block;\n    }\n    .wrapper {\n        display: block;\n        position: relative;\n    }\n    slot {\n        display: block;\n    }\n    :host([layout="responsive"]) > .wrapper > slot {\n        position: absolute;\n        top: 0;\n        left: 0;\n        width: 100%;\n        height: 100%;\n    }\n    @keyframes spinner {\n        to {\n            transform: rotate(360deg);\n        }\n    }\n    :host(.enx-image-loading)::after {\n        content: \'\';\n        position: absolute;\n        top: 50%;\n        left: 50%;\n        width: 20px;\n        height: 20px;\n        margin-top: -10px;\n        margin-left: -10px;\n        border-radius: 50%;\n        border: 2px solid rgba(0, 0, 0, 0.1);\n        border-top-color: rgba(0, 0, 0, 0.2);\n        animation: spinner 0.6s linear infinite;\n    }\n    :host(.enx-image-loading) {\n        box-shadow: inset 0 0 80px rgba(0, 0, 0, 0.1);\n    }\n    </style>\n    <div class="wrapper"><slot></slot></div>\n    '
;var r=Object.create(HTMLElement.prototype);o.prototype=r,r.constructor=o,Object.setPrototypeOf(o,HTMLElement),Object.defineProperties(o,{observedAttributes:{get:function(){return["aspect","layout"]}}
}),r.attributeChangedCallback=function(n,t,e){"aspect"===n?this.setAspect(e):"layout"===n&&this.setLayout(e)},r.setAspect=function(n){var t=parseFloat(n);!n||t?(this.aspect=t,
s.call(this)):console.warn("Invalid aspect",t,this)},r.setLayout=function(n){this.layout=n,s.call(this)},document.addEventListener("DOMContentLoaded",(function(){
return customElements.define("enx-image",o)}))}();
//# sourceMappingURL= https://sourcemap.prokerala.com/theme/unity/assets/js/enx-image.min.js.map?_=40a4fc9b</script>

                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="Z3E6U-CMBJ9-EQB2H-8R6YE-R27L6",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"Z3E6U-CMBJ9-EQB2H-8R6YE-R27L6",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e=""=="true"?1:0,t="",n="nml5ubaxbsipiymmuema-f-6dafb2fe8-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"718450","ak.ai":parseInt("467240",10),"ak.ol":"0","ak.cr":5,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"532c3f42","ak.r":36639,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":50368,"ak.gh":"23.36.67.244","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"bbr","ak.t":"1636606232","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==vZfVZg+AicEuTg8rmwYTQhOIlCypTU7voqvn+LTsnLJWOL/K0t29ZCWnJz/scGh0aqmTlIrzjuzhZOw7WR2mMc74yE00D9wAWLK11N5GU5aOcaMvkLxEZC9MQYl0zwtvOwhwSGfLXCCRpyWUn4GZESbVpXt+wK4SSqu1LwvTwGXVAmRSqBEAdkr83MisF3VrJuvkSNOd2uygw6OMJkMWQJNvZ9wdJjiU4hw5A6ZhGgcMEAAoasHxSSc3OuDlGRPzUab3Rp6HsWwErWx1Xn5yHWY/ezX8IcBBEkz4SoyDtlx/O8Ko/fO0xqxQV0HSkcF3UvFcYlgCJQ/MObaw+sU3fKM97TU4oLcdyVNxwOJgu3rw8euFghJVW1Vk6V3fVptwgbVVyjE8bQk6pPBp6itC9oyXUhfH9N9B9CbMIALLqCY=","ak.pv":"66","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
<body>
<div id=wrapper>
<header class=header>
<div class="header-main theme-bg">
<div class=container>
<div class="navbar-header clearfix">
<button id=btn-site-menu-toggle class="btn btn-nav-toggle btn-site-menu-toggle theme-loading-hide" aria-label="Toggle Menu" data-event-track=click:ab.site-header.site-menu><i aria-hidden=true class="icon icon-fw nav-icon icon-bars">&#8203;</i></button><a role=button id=btn-nav-brand class=btn-nav-brand href="/" data-event-track=click:ab.site-header.site-home>
<svg xmlns="http://www.w3.org/2000/svg" version=1.0 viewBox="0 0 760 150" width=141 height=28 class=nav-brand-logo>
<path fill="#FFF" d="M95.1 41h13.7v15.3a48 48 0 0113-13.4c4.5-3 9.2-4.5 14.2-4.5 3.7 0 7.6 1.2 11.8 3.6l-7 11.3a18.7 18.7 0 00-7-1.9c-4.5 0-8.8 1.9-13 5.6a34.8 34.8 0 00-9.5 17c-1.6 6-2.5 18-2.5 36.1v35.3H95.1V41z"/>
<path fill="#FFF" d="M186.8 38.4a54.3 54.3 0 0154.4 55.1c0 14.6-5.1 27.3-15.3 38.2a51 51 0 01-39.1 16.4 54.3 54.3 0 01-54.4-54.6c0-14.4 4.7-27 14.3-37.5a51.6 51.6 0 0140-17.6zm0 13.1A38.7 38.7 0 00158 64c-8 8.2-12 18.2-12 30 0 7.5 1.8 14.5 5.4 21a38.8 38.8 0 0014.8 15.1c6.3 3.6 13 5.3 20.5 5.3s14.3-1.7 20.5-5.3 11.2-8.6 14.8-15 5.5-13.6 5.5-21.2c0-11.7-4-21.7-12-29.9a38.7 38.7 0 00-28.8-12.4zm228.9 59.3l11.3 6c-3.7 7.2-8 13.1-12.9 17.6a51 51 0 01-37 13.7c-17 0-30.3-5.6-40-16.7s-14.3-23.8-14.3-37.9c0-13.2 4-25 12.2-35.3a49.8 49.8 0 0141.3-19.8c17.8 0 32 6.7 42.6 20.2a56.5 56.5 0 0111.5 35.7h-93.8c.2 12.1 4.1 22 11.6 29.8a37 37 0 0027.7 11.6 44.5 44.5 0 0028.3-10.1c3.6-3 7.4-8 11.5-14.8zm0-28.1a44.5 44.5 0 00-7.9-17.2 41.6 41.6 0 00-31.3-14.3c-10.2 0-19 3.3-26.4 10-5.4 4.7-9.4 12-12.2 21.5h77.8zm28.6-41.6H458v15.2c4.1-6 8.4-10.5 13-13.4s9.2-4.5 14.1-4.5c3.7 0 7.7 1.2 12 3.5l-7 11.4a18.7 18.7 0 00-7.2-1.9c-4.4 0-8.8 1.9-12.9 5.5a34.8 34.8 0 00-9.5 17.2c-1.7 5.9-2.5 18-2.5 36v35.3h-13.7V41z"/>
<path fill="#FFF" d="M589.2 41v104.4H576v-18c-5.6 7-12 12-19 15.5s-14.6 5.2-22.9 5.2a51 51 0 01-37.8-16A53.8 53.8 0 01480.6 93c0-15 5.3-28 15.8-38.6s23.3-16 38-16A49.1 49.1 0 01576 60.3V41h13.2zm-53.6 10.4a40.5 40.5 0 00-35.8 21 42.4 42.4 0 000 42 41.3 41.3 0 0035.7 21.3 42 42 0 0036-20.6 43 43 0 005.4-21.3 41.5 41.5 0 00-41.3-42.5zM82.2 18.6A36.1 36.1 0 0062.4 6.5C57 5 46.7 4.5 31.7 4.4L21 18.2h19.7c9.6 0 16.4.8 20.6 2.5 4.2 1.6 7.6 4.4 10.1 8.3 2.6 4 3.8 8.3 3.8 13 0 4.8-1.2 9.2-3.8 13.2-2.6 3.9-6 6.7-10.5 8.5a62.6 62.6 0 01-21.2 2.6L15.8 66V25l-14 18.3v102.1h14V79.8h10c17.6 0 29.5-.8 36-2.3a36.8 36.8 0 0020.5-12.3c5-6.1 7.5-13.9 7.5-23.3 0-9.3-2.5-17-7.6-23.2z"/>
<path fill="#FDCD08" d="M25.7 4.4h-24v31l24-31zm236 9.9V.8h-13.5v30.9l13.4-17.4z"/>
<path fill="#FFF" d="M272.4 90.8l57.3-49.7H310l-48.4 42V22l-13.4 17.4v106h13.4v-47l52.6 47H333l-60.7-54.5z"/>
<path fill="#FDCD08" d="M618.6 16.9V.9h-13.4v33.4l13.4-17.4z"/>
<path fill="#FFF" d="M605.2 42v103.4h13.4V24.6L605.2 42zm127 79.7c0-5 2.8-9.3 6.7-11.7V41h-13.2v19.3a49.3 49.3 0 00-41.5-21.9 51.6 51.6 0 00-38 16A52.8 52.8 0 00630.2 93c0 15.4 5.2 28.4 15.7 39.1s23 16 37.8 16c8.3 0 16-1.7 23-5.1s13.3-8.6 19-15.4v17.9h13.1v-12c-4-2.4-6.6-6.8-6.6-11.7zm-11-6.6c-3.5 6.4-8.5 11.4-15.1 15s-13.6 5.6-20.9 5.6a41.1 41.1 0 01-35.6-21.3 42.3 42.3 0 0115-57.6 40.5 40.5 0 0120.7-5.5 41.5 41.5 0 0141.3 42.4c0 8-1.8 15.1-5.3 21.4z"/>
<path fill="#FDCD08" d="M758.4 122a11.7 11.7 0 11-23.4 0 11.7 11.7 0 0123.4 0"/>
</svg>
</a>
<button id=btn-search-toggle class="btn btn-nav-toggle btn-search-toggle theme-loading-hide" aria-label="Toggle Search" data-event-track=click:ab.site-header.site-toggle-search><i aria-hidden=true class="icon icon-fw nav-icon icon-search btn-search-icon">&#8203;</i></button>
<a role=button id=btn-site-login class="btn btn-site-login btn-icon-label pull-right theme-loading-hide" href="/account/" aria-label=Login data-event-track=click:ab.site-header.site-login><i aria-hidden=true class="icon icon-fw nav-icon icon-user">&#8203;</i> <span class=nav-icon-label>Login</span></a>
<form id=form-site-search method=get action="/search/" class="form-site-search theme-loading-hide" target=_top novalidate>
<span class=input-site-search-wrapper><input id=input-site-search type=text name=q class="google-cse-input input-site-search" placeholder=Search autocomplete=off></span><div class=input-group-site-search>
<button class="btn btn-default btn-site-search" type=submit><i aria-hidden=true class="icon icon-fw icon-search btn-search-icon">&#8203;</i><span class=icon-label>Go</span></button>
</div>
</form>
</div>
</div>
</div>
<div class=nav-main-wrapper>
<div class="wdgt-base wdgt wdgt-menu nav-main container"><ul class="wdgt-menu-list nav nav-main-list"><li><a href="/astrology/weekly-horoscope/"><i class="icon icon-fw icon-sun-o">&#x200b;</i> Weekly Horoscope</a></li><li><a href="/astrology/monthly-horoscope/"><i class="icon icon-fw icon-arrow-circle-right">&#x200b;</i> Monthly Horoscope</a></li><li><a href="/astrology/rashifal/"><i class="icon icon-fw icon-arrow-circle-right">&#x200b;</i> राशिफल</a></li><li><a href="/astrology/birth-chart/"><i class="icon icon-fw icon-file-text-o">&#x200b;</i> Birth Chart</a></li><li><a href="/astrology/kundali-matching/"><i class="icon icon-fw icon-heart">&#x200b;</i> Kundli Matching</a></li><li><a href="/astrology/panchang/"><i class="icon icon-fw icon-calendar">&#x200b;</i> Panchang</a></li><li><a href="/entertainment/love-meter/"><i class="icon icon-fw icon-heart-o">&#x200b;</i> Love Calculator</a></li></ul></div>
</div>
<div class=adm-header-wrapper>
<div class="wdgt-base wdgt wdgt-ad-widget wdgt-adm-header tc"><ins class=adm-wrapper>
<div class="adm-unit clearfix" data-adm-id=PK_Astrology_Header.GooglePublisherTags.PK_Astrology_Header_DFP>
<div id=PK_Astrology_Header_DFP></div>
<script>gptUnits.push(function() { googletag.display("PK_Astrology_Header_DFP"); })</script></div>
</ins></div>
</div>
</header><main class="body container">
<aside class="additional-content clearfix">
<div class="wdgt-base wdgt wdgt-block"><div class=astrology-wdgt-slider-cards-wrapper>
<div class="astrology-wdgt-slider-cards grid-col grid-col-xs-1" data-event-track="view:ab.wdgt-astrology-related.{device}-header-view">
<div><a href="/astrology/nakshatra-finder/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/nakshatra-finder.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/nakshatra-finder.png" width=104 height=104 alt="Nakshatra Finder"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/nakshatra-finder.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/nakshatra-finder.png" width=104 height=104 alt="Nakshatra Finder"></picture></enx-image>
<span class=caption>Nakshatra Finder</span></a></div>
<div><a href="/astrology/horoscope/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/daily-horoscope.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/daily-horoscope.png" width=104 height=104 alt="Daily Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/daily-horoscope.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/daily-horoscope.png" width=104 height=104 alt="Daily Horoscope"></picture></enx-image>
<span class=caption>Daily Horoscope</span></a></div>
<div><a href="/astrology/weekly-horoscope/?&amp;utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/weekly-horoscope.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/weekly-horoscope.png" width=104 height=104 alt="Weekly Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/weekly-horoscope.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/weekly-horoscope.png" width=104 height=104 alt="Weekly Horoscope"></picture></enx-image>
<span class=caption>Weekly Horoscope</span></a></div>
<div><a href="/astrology/monthly-horoscope/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/monthly-horoscope.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/monthly-horoscope.png" width=104 height=104 alt="Monthly Horoscope for March 2021"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/monthly-horoscope.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/monthly-horoscope.png" width=104 height=104 alt="Monthly Horoscope for March 2021"></picture></enx-image>
<span class=caption>August Horoscope</span></a></div>
<div><a href="/astrology/porutham/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/horoscope-matching.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/horoscope-matching.png" width=104 height=104 alt=" Horoscope Matching"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/horoscope-matching.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/horoscope-matching.png" width=104 height=104 alt=" Horoscope Matching"></picture></enx-image>
<span class=caption>Horoscope Matching</span></a></div>
<div><a href="/astrology/kundali-matching/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/kundli-matching.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/kundli-matching.png" width=104 height=104 alt="Kundli Matching"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/kundli-matching.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/kundli-matching.png" width=104 height=104 alt="Kundli Matching"></picture></enx-image>
<span class=caption>Kundli Matching</span></a></div>
<div><a href="/astrology/birth-chart/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/birth-chart.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/birth-chart.png" width=104 height=104 alt="Birth Chart"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/birth-chart.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/birth-chart.png" width=104 height=104 alt="Birth Chart"></picture></enx-image>
<span class=caption>Birth Chart</span></a></div>
<div><a href="/astrology/choghadiya.php?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/choghadiya.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/choghadiya.png" width=104 height=104 alt=Choghadiya></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/choghadiya.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/choghadiya.png" width=104 height=104 alt=Choghadiya></picture></enx-image>
<span class=caption>Choghadiya Today</span></a></div>
<div><a href="/astrology/kundli/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/kundli.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/kundli.png" width=104 height=104 alt=Kundli></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/kundli.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/kundli.png" width=104 height=104 alt=Kundli></picture></enx-image>
<span class=caption>Kundli</span></a></div>
<div><a href="/astrology/panchang/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/panchangam.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/panchangam.png" width=104 height=104 alt=Panchangam></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/panchangam.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/panchangam.png" width=104 height=104 alt=Panchangam></picture></enx-image>
<span class=caption>Panchangam</span></a></div>
<div><a href="/astrology/rahukalam/?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/rahu-kaal-timings.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/rahu-kaal-timings.png" width=104 height=104 alt="Rahu Kaal Timings"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/rahu-kaal-timings.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/rahu-kaal-timings.png" width=104 height=104 alt="Rahu Kaal Timings"></picture></enx-image>
<span class=caption>Today's Rahu Kalam</span></a></div>
<div><a href="/astrology/mangal-dosha/manglik.php?utm_source=PK-astrology-header-wdgt&amp;utm_medium=astrology-related&amp;utm_campaign=astrology-header-wdgt" data-event-track="click:ab.wdgt-astrology-related.{device}-header-click">
<enx-image thumb layout=responsive aspect=1 class=astrology-wdgt-slider-img><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/mangal-dosha.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/mangal-dosha.png" width=104 height=104 alt="Mangal Dosha"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/mangal-dosha.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/mangal-dosha.png" width=104 height=104 alt="Mangal Dosha"></picture></enx-image>
<span class=caption>Mangal Dosha</span></a></div>
</div>
</div>
</div>
<nav>
<ol class=breadcrumb aria-label=breadcrumbs itemscope itemtype="http://schema.org/BreadcrumbList">
<li itemprop=itemListElement itemscope itemtype="http://schema.org/ListItem">
<a itemprop=item href="/"><span itemprop=name>Home</span></a>
<meta itemprop=position content=1>
</li>
<li itemprop=itemListElement itemscope itemtype="http://schema.org/ListItem">
<a itemprop=item href="/astrology/">
<span itemprop=name>Astrology</span>
</a>
<meta itemprop=position content=2>
</li>
<li itemprop=itemListElement itemscope itemtype="http://schema.org/ListItem">
<a itemprop=item href="/astrology/horoscope/">
<span itemprop=name>Horoscope</span>
</a>
<meta itemprop=position content=3>
</li>
</ol>
</nav>
</aside>
<div class=main-content>
<header class=page-header>
<h1>Today's Pisces Horoscope - Thursday, November 11, 2021</h1>
<div class=share-info-wrapper data-icon=1 data-inverted=1 data-paytm-hide></div> </header>
<span hidden data-require-auth class="btn btn-warning btn-xs pull-right a" data-href="/manage/cms/pages.php?mode=page&amp;page_key=astrology_horoscope_pisces&amp;action=update"><i aria-hidden=true class="icon icon-pencil">&nbsp;</i></span>
<p>Know what astrology and the planets have in store for people born under Pisces sign. Astrology reveals the effect of planets on Pisces today.</p>
<figure class=article-image>
<enx-image layout=responsive aspect=2><noscript class=enx-image-fallback>
<picture>
<source srcset="/astrology/assets/img/header/horoscope/pisces-horoscope.webp" type="image/webp">
<img loading=lazy src="/astrology/assets/img/header/horoscope/pisces-horoscope.jpg" width=700 height=350 alt="Pisces Horoscope">
</picture>
</noscript>
<picture>
<source data-srcset="/astrology/assets/img/header/horoscope/pisces-horoscope.webp" type="image/webp">
<img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20200%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/header/horoscope/pisces-horoscope.jpg" width=700 height=350 alt="Pisces Horoscope">
</picture>
</enx-image>
</figure>
<nav class="nav-icon-bar tc bordered shadow">
<a data-event-track=click:ab.horoscope-nav.boa-nav-icon-bar href="/astrology/horoscope/?sign=pisces&amp;day=yesterday" rel=nofollow title="Horoscope for yesterday"><i aria-hidden=true class="icon icon-angle-left">&#8203;</i> Yesterday</a>
<a class=active data-event-track=click:ab.horoscope-nav.boa-nav-icon-bar href="/astrology/horoscope/?sign=pisces" rel=next title="Today's Horoscope"><i aria-hidden=true class="icon icon-clock-o">&#8203;</i> Today</a>
<a data-event-track=click:ab.horoscope-nav.boa-nav-icon-bar href="/astrology/horoscope/?sign=pisces&amp;day=tomorrow" rel=nofollow title="Horoscope for tomorrow"><i aria-hidden=true class="icon icon-angle-right">&#8203;</i> Tomorrow</a>
<a data-event-track=click:ab.horoscope-nav.boa-other-horoscope href="/astrology/weekly-horoscope/pisces.html" title="Weekly Horoscope"><i aria-hidden=true class="icon icon-calendar">&#8203;</i> Weekly</a>
<a data-event-track=click:ab.horoscope-nav.boa-other-horoscope href="/astrology/monthly-horoscope/pisces.html" title="Monthly Horoscope"><i aria-hidden=true class="icon icon-calendar-o">&#8203;</i> Monthly</a>
</nav>
<article>
<h2>Pisces Daily Horoscope </h2>
<div class=horoscope-panel>
<p>The day may turn out to be somewhat bizarre. Event which you never expected have a high chance of happening today. It is important that you take note of the planetary energies and try to understand the direction to which they are pushing you. Detecting the right path at this juncture can have a revolutionary effect on your life.</p>
<div class="scroll-break-ponit item-block"><a href="/astrology/monthly-horoscope/pisces.html">Pisces horoscope for November &rarr;</a></div>
<div class=adm-wrapper>
<div class="adm-unit clearfix" data-adm-id=PK_Astrology_Rectangle_Middle.GooglePublisherTags.PK_Astrology_Rectangle_Middle_DFP>
<div id=PK_Astrology_Rectangle_Middle_DFP></div>
<script>gptUnits.push(function() { googletag.display("PK_Astrology_Rectangle_Middle_DFP"); })</script></div>
</div>
</div>
<h2>Pisces Health & Wellness Horoscope </h2>
<div class=horoscope-panel>
<p>You may dream in your sleep which may provide you with a very useful guidance. You have been ignoring the advice of specialists to switch to homeopathic care! Consequently you may experience strain in all parts of your body! Ask some one to be close to you when you go for ablutions!</p>
</div>
<h2>Pisces Daily Love & Relationship Horoscope </h2>
<div class=horoscope-panel>
<p>Romantic involvement with a colleague will create unnecessary tension and difficulties. Try to keep your personal life separate from professional life. Try to join a fitness and health program with your beloved to reduce the level of stress in your relationship and in your mind as well. These apprehensions may make you suffer from feeling of insecurity in relationship.</p>
<p class="text-muted i">Understand compatibility with <a class=i href="/astrology/love-horoscope/"> love horoscope. </a>
Check love percentage using<a class=i target=_blank href="/entertainment/love-meter/"> love calculator.</a></p>
</div>
<h2>Pisces Career & Money Horoscope </h2>
<div class=horoscope-panel>
<p>Be careful with your finances. You need to take a cold look at the small expenses which could otherwise accumulate to rather large proportions. Though your individual expenses are small, you need to limit your spending if you want to avoid serious money trouble in the future. You should also start looking for additional ways of increasing your income.</p>
</div>
</article>
<div class=adm-wrapper>
<div class="adm-unit clearfix" data-adm-id=PK_Astrology_Rectangle_BTF.AdsenseAsync.PK_Astrology_Rectangle_BTF_AS>
<ins class="adsbygoogle adm-responsive-rectangle" data-ad-client=ca-pub-2107538958244175 data-ad-slot=4726615225 data-ad-format=auto data-full-width-responsive=true></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div>
</div>
<nav class="nav-icon-bar tc bordered shadow d-flex justify-content-center floating-bottom-right" data-plugin=bannerpromotion>
<a data-event-track=click:ab.horoscope-nav.eoa-nav-icon-bar href="/astrology/horoscope/?sign=pisces&amp;day=yesterday" rel=nofollow title="Horoscope for yesterday"><i aria-hidden=true class="icon icon-angle-left">&#8203;</i> Yesterday</a>
<a data-event-track=click:ab.horoscope-nav.eoa-nav-icon-bar href="/astrology/horoscope/?sign=pisces&amp;day=tomorrow" rel=nofollow title="Horoscope for tomorrow"><i aria-hidden=true class="icon icon-angle-right">&#8203;</i> Tomorrow</a>
<a data-event-track=click:ab.horoscope-nav.eoa-other-horoscope href="/astrology/weekly-horoscope/" title="Weekly Horoscope"><i aria-hidden=true class="icon icon-calendar">&#8203;</i> Weekly</a>
<a data-event-track=click:ab.horoscope-nav.eoa-other-horoscope href="/astrology/monthly-horoscope/" title="Monthly Horoscope"><i aria-hidden=true class="icon icon-calendar-o">&#8203;</i> Monthly</a>
<a data-event-track=click:ab.horoscope-nav.eoa-other-horoscope href="/astrology/monthly-horoscope/" title="Love Horoscope"><i aria-hidden=true class="icon icon-heart-o">&#8203;</i> Love</a>
</nav>
<p>To unfold what lies further ahead, take a look at your <a href="/astrology/weekly-horoscope/pisces.html">Pisces weekly</a> and <a href="/astrology/monthly-horoscope/pisces.html">Pisces monthly</a> horoscope. To read Pisces horoscope in Hindi, see <a href="/astrology/rashifal/?sign=meena">Meena rashifal today</a>.</p>
<p>Pisces daily horoscope highlighting your day in general, love &amp; romantic magnetism, career &amp; wealth potentials, health and wellness for Pisces today etc...</p>
<h4>Horoscope for other zodiac signs</h4>
<div class="zodiac-signs full-width item-block scroller">
<div class="zodiac-sign-list ">
<ul class="tc grid-col grid-col-xs-4 grid-col-sm-3  holder">
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=aries">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/aries.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/aries.jpg" width=100 height=100 alt="Aries Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/aries.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/aries.jpg" width=100 height=100 alt="Aries Horoscope"></picture></enx-image>
</span>
<span class=caption>Aries</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=taurus">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/taurus.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/taurus.jpg" width=100 height=100 alt="Taurus Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/taurus.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/taurus.jpg" width=100 height=100 alt="Taurus Horoscope"></picture></enx-image>
</span>
<span class=caption>Taurus</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=gemini">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/gemini.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/gemini.jpg" width=100 height=100 alt="Gemini Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/gemini.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/gemini.jpg" width=100 height=100 alt="Gemini Horoscope"></picture></enx-image>
</span>
<span class=caption>Gemini</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=cancer">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/cancer.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/cancer.jpg" width=100 height=100 alt="Cancer Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/cancer.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/cancer.jpg" width=100 height=100 alt="Cancer Horoscope"></picture></enx-image>
</span>
<span class=caption>Cancer</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=leo">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/leo.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/leo.jpg" width=100 height=100 alt="Leo Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/leo.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/leo.jpg" width=100 height=100 alt="Leo Horoscope"></picture></enx-image>
</span>
<span class=caption>Leo</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=virgo">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/virgo.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/virgo.jpg" width=100 height=100 alt="Virgo Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/virgo.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/virgo.jpg" width=100 height=100 alt="Virgo Horoscope"></picture></enx-image>
</span>
<span class=caption>Virgo</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=libra">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/libra.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/libra.jpg" width=100 height=100 alt="Libra Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/libra.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/libra.jpg" width=100 height=100 alt="Libra Horoscope"></picture></enx-image>
</span>
<span class=caption>Libra</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=scorpio">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/scorpio.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/scorpio.jpg" width=100 height=100 alt="Scorpio Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/scorpio.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/scorpio.jpg" width=100 height=100 alt="Scorpio Horoscope"></picture></enx-image>
</span>
<span class=caption>Scorpio</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=sagittarius">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/sagittarius.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/sagittarius.jpg" width=100 height=100 alt="Sagittarius Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/sagittarius.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/sagittarius.jpg" width=100 height=100 alt="Sagittarius Horoscope"></picture></enx-image>
</span>
<span class=caption>Sagittarius</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=capricorn">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/capricorn.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/capricorn.jpg" width=100 height=100 alt="Capricorn Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/capricorn.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/capricorn.jpg" width=100 height=100 alt="Capricorn Horoscope"></picture></enx-image>
</span>
<span class=caption>Capricorn</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=aquarius">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/aquarius.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/aquarius.jpg" width=100 height=100 alt="Aquarius Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/aquarius.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/aquarius.jpg" width=100 height=100 alt="Aquarius Horoscope"></picture></enx-image>
</span>
<span class=caption>Aquarius</span>
</a>
</li>
<li class=zodiac-sign>
<a href="/astrology/horoscope/?sign=pisces">
<span class=fix-width>
<enx-image thumb layout=responsive aspect=1><noscript class=enx-image-fallback><picture><source srcset="/astrology/assets/img/home/pisces.webp" type="image/webp"><img loading=lazy src="/astrology/assets/img/home/pisces.jpg" width=100 height=100 alt="Pisces Horoscope"></picture></noscript><picture><source data-srcset="/astrology/assets/img/home/pisces.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" data-src="/astrology/assets/img/home/pisces.jpg" width=100 height=100 alt="Pisces Horoscope"></picture></enx-image>
</span>
<span class=caption>Pisces</span>
</a>
</li>
</ul>
</div>
</div>
<p>Back to <a href="/astrology/horoscope/">horoscope main page &rarr;</a></p>
<nav class="article-tags tl">
<a href="/astrology/">Astrology</a>
<a href="/astrology/monthly-horoscope/">Monthly Horoscope</a>
<a href="/astrology/weekly-horoscope/">Weekly Horoscope</a>
<a href="/astrology/love-horoscope/">Love Horoscope</a>
</nav>
<div>
<h4>Related Links</h4>
<div class="grid-col grid-col-xs-12 grid-col-md-6 f-sans-serif">
<div class="media-card mc-list" data-href="/astrology/birth-chart/">
<div class=media-card-image>
<enx-image thumb layout=responsive aspect=1.5><noscript class=enx-image-fallback><picture><source srcset="/assets/img/wdgt/modern/icons/birth-chart.webp" type="image/webp"><img loading=lazy src="/assets/img/wdgt/modern/icons/birth-chart.jpg" width=150 height=100 alt="Birth Chart"></picture></noscript><picture><source data-srcset="/assets/img/wdgt/modern/icons/birth-chart.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20100'%3E%3C/svg%3E" data-src="/assets/img/wdgt/modern/icons/birth-chart.jpg" width=150 height=100 alt="Birth Chart"></picture></enx-image>
</div>
<div class=media-card-caption>
<a href="/astrology/birth-chart/" data-event-track=click:ab.horoscope.related-link>
<p class=no-margin>Get your birth chart based on your birth date</p></a>
</div>
</div>
<div class="media-card mc-list" data-href="/astrology/mangal-dosha/manglik.php">
<div class=media-card-image>
<enx-image thumb layout=responsive aspect=1.5><noscript class=enx-image-fallback><picture><source srcset="/assets/img/wdgt/modern/icons/mangal-dosha.webp" type="image/webp"><img loading=lazy src="/assets/img/wdgt/modern/icons/mangal-dosha.jpg" width=150 height=100 alt="Mangal Dosha"></picture></noscript><picture><source data-srcset="/assets/img/wdgt/modern/icons/mangal-dosha.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20100'%3E%3C/svg%3E" data-src="/assets/img/wdgt/modern/icons/mangal-dosha.jpg" width=150 height=100 alt="Mangal Dosha"></picture></enx-image>
</div>
<div class=media-card-caption>
<a href="/astrology/mangal-dosha/manglik.php" data-event-track=click:ab.horoscope.related-link>
<p class=no-margin>Are you manglik? Check its presence in your birth chart.</p></a>
</div>
</div>
<div class="media-card mc-list" data-href="/astrology/porutham/">
<div class=media-card-image>
<enx-image thumb layout=responsive aspect=1.5><noscript class=enx-image-fallback><picture><source srcset="/assets/img/wdgt/modern/icons/marriage-matching.webp" type="image/webp"><img loading=lazy src="/assets/img/wdgt/modern/icons/marriage-matching.jpg" width=150 height=100 alt="Horoscope Matching"></picture></noscript><picture><source data-srcset="/assets/img/wdgt/modern/icons/marriage-matching.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20100'%3E%3C/svg%3E" data-src="/assets/img/wdgt/modern/icons/marriage-matching.jpg" width=150 height=100 alt="Horoscope Matching"></picture></enx-image>
</div>
<div class=media-card-caption>
<a href="/astrology/porutham/" data-event-track=click:ab.horoscope.related-link>
<p class=no-margin>Marriage horoscope matching based on kundli milan.</p></a>
</div>
</div>
<div class="media-card mc-list" data-href="/astrology/nakshatra-finder/">
<div class=media-card-image>
<enx-image thumb layout=responsive aspect=1.5><noscript class=enx-image-fallback><picture><source srcset="/assets/img/wdgt/modern/icons/nakshatra-finder.webp" type="image/webp"><img loading=lazy src="/assets/img/wdgt/modern/icons/nakshatra-finder.jpg" width=150 height=100 alt="Nakshatra Finder"></picture></noscript><picture><source data-srcset="/assets/img/wdgt/modern/icons/nakshatra-finder.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20100'%3E%3C/svg%3E" data-src="/assets/img/wdgt/modern/icons/nakshatra-finder.jpg" width=150 height=100 alt="Nakshatra Finder"></picture></enx-image>
</div>
<div class=media-card-caption>
<a href="/astrology/nakshatra-finder/" data-event-track=click:ab.horoscope.related-link>
<p class=no-margin>Nakshatra Finder &amp; Birth Star Calculator.</p></a>
</div>
</div>
<div class="media-card mc-list" data-href="/astrology/kundali-matching/">
<div class=media-card-image>
<enx-image thumb layout=responsive aspect=1.5><noscript class=enx-image-fallback><picture><source srcset="/assets/img/wdgt/modern/icons/kundali-matching.webp" type="image/webp"><img loading=lazy src="/assets/img/wdgt/modern/icons/kundali-matching.jpg" width=150 height=100 alt="Kundali Milan"></picture></noscript><picture><source data-srcset="/assets/img/wdgt/modern/icons/kundali-matching.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20100'%3E%3C/svg%3E" data-src="/assets/img/wdgt/modern/icons/kundali-matching.jpg" width=150 height=100 alt="Kundali Milan"></picture></enx-image>
</div>
<div class=media-card-caption>
<a href="/astrology/kundali-matching/" data-event-track=click:ab.horoscope.related-link>
<p class=no-margin>Kundli Matching - Calculate marriage horoscope compatibility.</p></a>
</div>
</div>
<div class="media-card mc-list" data-href="/numerology/">
<div class=media-card-image>
<enx-image thumb layout=responsive aspect=1.5><noscript class=enx-image-fallback><picture><source srcset="/assets/img/wdgt/modern/icons/numerology4.webp" type="image/webp"><img loading=lazy src="/assets/img/wdgt/modern/icons/numerology4.jpg" width=150 height=100 alt=Numerology></picture></noscript><picture><source data-srcset="/assets/img/wdgt/modern/icons/numerology4.webp" type="image/webp"><img loading=lazy src="data:image/svg+xml,%3Csvg%20class='enx-image-placeholder'%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20100'%3E%3C/svg%3E" data-src="/assets/img/wdgt/modern/icons/numerology4.jpg" width=150 height=100 alt=Numerology></picture></enx-image>
</div>
<div class=media-card-caption>
<a href="/numerology/" data-event-track=click:ab.horoscope.related-link>
<p class=no-margin>Numerology, lucky numbers &amp; effect of numbers.</p></a>
</div>
</div>
</div>
</div>
</div>
<aside class=side-content>
<div class=wdgt-group><div class=wdgt-group-inner>
<section class="wdgt-base wdgt wdgt-item-list wdgt-theme-light"><div class=wdgt-content><h3 class="wdgt-title section-title">Astrology links</h3><ul class="wdgt-view-list  shadow" style="--wdgt-list-icon-bg: #009900; --wdgt-list-icon-fg: #ffffff;">
<li>
<a href="/astrology/porutham/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Horoscope matching to find marriage match </a>
</li>
<li>
<a href="/astrology/kundli/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Free janam kundli online </a>
</li>
<li>
<a href="/astrology/sade-sati.php">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Shani sade sati &amp; Saturn transit report </a>
</li>
<li>
<a href="/astrology/reports/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Buy personalized astrology reports </a>
</li>
<li>
<a href="/astrology/kundali-matching/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Kundali matching for marriage </a>
</li>
</ul></div></section>
<section class="wdgt-base wdgt wdgt-block wdgt-theme-light"><div class=wdgt-content><div class=adm-wrapper><ins class=tfOuterWrapper style="display:inline-table;position:relative;width:300px;height:250px;margin:0;padding:0;border:none;visibility:visible;"><ins class=tfInnerWrapper style="display:block;position:relative;width:300px;height:250px;margin:0;padding:0;border:none;visibility:visible;"><iframe loading=lazy src="/res/prokerala/pk_reports.cache.html?20210914" width=300 height=250 frameborder=0 scrolling=no sandbox="allow-scripts allow-forms allow-top-navigation allow-same-origin" style="left:0;position:absolute;top:0;" title="Know your horoscope"></iframe></ins></ins></div>
</div></section>
<section class="wdgt-base wdgt wdgt-item-list wdgt-theme-light"><div class=wdgt-content><h3 class="wdgt-title section-title">More From Astrology</h3><ul class="wdgt-view-list  shadow" style="--wdgt-list-icon-bg: #009900; --wdgt-list-icon-fg: #ffffff;">
<li>
<a href="/astrology/horoscope/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Today's horoscope </a>
</li>
<li>
<a href="/astrology/nakshatra-finder/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Birth star &amp; nakshatra calculator </a>
</li>
<li>
<a href="/astrology/mangal-dosha/manglik.php">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Are you manglik? Mangal dosha calculator </a>
</li>
<li>
<a href="/astrology/panchang/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Panchang </a>
</li>
<li>
<a href="/astrology/natal-chart/">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Natal chart western style </a>
</li>
<li>
<a href="/astrology/jathakam.php">
<span class=wdgt-view-icon><i class="icon icon-arrow-right">&#8203;</i></span>
Jathakam </a>
</li>
</ul></div></section>
<section class="wdgt-base wdgt wdgt-separator wdgt-theme-light wdgt-sticky wdgt-desktop-only"><div class=wdgt-content></div></section>
<section class="wdgt-base wdgt wdgt-ad-widget wdgt-theme-light wdgt-sticky wdgt-desktop-only"><div class=wdgt-content><ins class=adm-wrapper>
<div class="adm-unit clearfix" data-adm-id=PK_Astrology_SideContent_BTF.GooglePublisherTags.PK_Astrology_SideContent_BTF_DFP>
<div id=PK_Astrology_SideContent_BTF_DFP></div>
<script>gptUnits.push(function() { googletag.display("PK_Astrology_SideContent_BTF_DFP"); })</script></div>
</ins></div></section>
</div></div>
</aside>
</main>
<footer class=footer>
<nav class="nav-content-footer theme-border" id=footer>
<div class=container>
<div class="wdgt-base wdgt wdgt-menu footer-section-links scroller"><ul class="wdgt-menu-list nav holder"><li><a href="/astrology/kundali-matching/">Kundli Matching</a></li><li><a href="/numerology/">Numerology</a></li><li><a href="/astrology/tithi/">Tithi Today</a></li><li><a href="/astrology/astrology-api.htm">Astrology API</a></li><li><a href="/astrology/planet-positions.php">Planetary Positions</a></li><li><a href="/astrology/muhurat/">Shubh Muhurat</a></li><li><a href="/astrology/choghadiya.php">Choghadiya</a></li><li><a href="/astrology/rahukalam/">Rahu Timings</a></li><li><a href="/feng-shui/">Feng Shui</a></li><li><a href="/festivals/">Festivals</a></li></ul></div>
</div>
</nav>
<nav class=container>
<div class="footer-nav-wrapper grid-col grid-col-xs-12 grid-col-sm-6 grid-col-md-4">
</div>
</nav>
<div class=footer-main-container>
<div class=follow-us-networks-wrapper>
<div class=follow-us-network-items>
<span class=t-large>Follow us on</span>
<div class=social-media-profiles>
<a rel=me href="https://www.pinterest.com/prokerala"><i aria-hidden=true class="icon icon-fw icon-pinterest pinterest">&#8203;</i></a>
<a rel=me href="https://www.facebook.com/Prokerala"><i aria-hidden=true class="icon icon-fw icon-facebook facebook">&#8203;</i></a>
<a rel=me href="https://twitter.com/Prokerala"><i aria-hidden=true class="icon icon-fw icon-twitter twitter">&#8203;</i></a>
<a rel=me href="https://www.youtube.com/c/Prokerala"><i aria-hidden=true class="icon icon-fw icon-youtube-play youtube">&#8203;</i></a>
</div>
</div>
</div>
<div class="footer-link-wrapper clearfix">
<ul class=nav>
<li><a href="/astrology/monthly-horoscope/">November Horoscope</a></li>
<li><a href="/downloads/ringtones/">Ringtones</a></li>
<li><a href="/entertainment/love-meter/">Love Calculator</a></li>
<li><a href="/kids/baby-gender/chinese-gender-predictor.php">Gender Prediction</a></li>
</ul>
<ul class=nav>
<li><a href="/astrology/">Astrology</a></li>
<li><a href="/kids/baby-names/">Baby Names</a></li>
<li><a href="/astrology/horoscope/">Daily Horoscope</a></li>
<li><a href="/news/finance/currency.php">Currency Converter</a></li>
</ul>
</div>
<div class="contact-us t-sm">
<div>
<div class=contact-wrapper>
<span>Ennexa Technologies Pvt.Ltd. <br>XI/476, Manganam, Kottayam, <span class=address-block>Kerala, India</span></span>
</div>
<div class=contact-wrapper>
<span class=t-large>Call us : <a href=tel:18004250053>1800 425 0053</a></span>
<span>Mon to Fri - 10 AM to 5 PM</span>
</div>
</div>
</div>
</div>
<span class=clearfix>&#8203;</span>
<div class="f-sans-serif clear-fix">
<div class="footer-container tc">
<span class="copyright t-small">&copy; 2005-21 Ennexa Technologies Pvt. Ltd.</span>
<nav class="footer-links tc t-large">
<span class=footer-link data-href="https://www.prokerala.com/privacy.htm">Privacy</span>
<span class=footer-link data-href="https://www.prokerala.com/terms.htm">TOS</span>
<span class=footer-link data-href="https://www.prokerala.com/disclaimer.htm">Disclaimer</span>
<span class=footer-link data-href="https://www.prokerala.com/cookie.htm">Cookies</span>
<a class=footer-link href="/contact.php">Contact</a>
</nav>
</div>
</div>
</footer>
<script>"use strict";!function(){function n(n,o){var i,t,e=o;Array.isArray(o)?(n=(i=e.shift().split("."))[0]+".ready",t=this,o=function(){(t=i[1]?t[i.shift()]:t)[i.shift()].apply(t,e)
}):"function"!=typeof o&&(console.error("[DRCB] Invalid arguments",arguments),o=noop),$.when(n).then(o)}window.polyfillReady=function(){_DRCB.push=n.bind(window,"$.ready"),$.done("$.ready"),
_DRCB.splice(0,_DRCB.length).forEach(_DRCB.push)},window.fetch&&Object.assign&&polyfillReady()}();
//# sourceMappingURL= https://sourcemap.prokerala.com/theme/unity/assets/js/polyfill-loader.min.js.map?_=79a9a05
;</script>
<script>var WIDGET_SET = 'e10a5ce1d5df5cc7492a003d364e59f0',
        BASE_URL = 'https://www.prokerala.com',
        SHARE_COUNT = {"share_uri":"\/astrology\/horoscope\/","share_time_updated":0};</script>
<script>"use strict";_DRCB.push(function(){var t,e=(t="ua_tracked",(document.cookie.match("(^|;) *"+t+"=([^;]*)")||"")[2]);window.addEventListener("load",function(){e||loadScript$("https://www.prokerala.com/static/theme/unity/assets/js/uat.min.js?_=b4240dfa"),document.documentElement&&document.documentElement.classList.contains("paytm-mini-app")||require(["/theme/unity/assets/js/plugin-shareinfo@47d97cc"],function(t){t.default.init(SHARE_COUNT,BASE_URL)})}),loadScript$("https://www.prokerala.com/static/theme/unity/assets/js/amd.min.js?_=fddc4e9f"),loadScript$(window.BROWSER_GRADE?"https://www.prokerala.com/static/theme/unity/assets/js/theme-enhanced.min.js?_=57672153":"https://www.prokerala.com/static/theme/unity/assets/js/theme-core.min.js?_=5e0d7465"),void 0!==e&&"0"===e[1]&&$.done("adb.detected",{status:!0})});var winW=window.innerWidth||document.documentElement&&document.documentElement.clientWidth||document.body&&document.body.clientWidth;$$(".adm-unit[data-adm-id*=_Rectangle_]").forEach(function(t){winW>960&&t.offsetWidth&&t.offsetWidth<600&&_DRCB.push(["Logger.log","Limited Ad "+document.location.href])});</script>
<script>loadScript$("https://securepubads.g.doubleclick.net/tag/js/gpt.js");</script>
<script>//<![CDATA[
try {
  window.googletag=window.googletag||{};
  googletag.cmd=googletag.cmd||[];
  window.AdmGpt = {
    slots: [],
    slotCount: 0,
    mappings: {},
    add: function(id, slot) {
        this.slots[id] = slot;
        this.slotCount++;
    },
    refresh: function (ids) {
      googletag.pubads().refresh(ids.map(AdmGpt.get))
    },
    get: function (id) {
      return AdmGpt.slots[id];
    }
  };
  (function(){
    var mh = [[320, 100], [320, 50], [1, 1]], dh = [[728, 90], [468, 60]], r = [[360, 300], [336, 280], [300, 250]];
    AdmGpt.mappings = {
      header: [
        [[970, 850], [[970, 90], [970, 250]].concat(dh, mh)],
        [[728, 0], [[970, 90]].concat(dh, mh)],
        [[0, 0], [[300, 250]]]
      ],
      all: [[[1152, 0], dh.concat([[1, 1]]).concat(r)], [[360, 0], r], [[0, 0], [[300, 250], [1, 1]]]],
      banner: [[[1152, 0], dh], [[480, 0], [[468, 60]].concat(mh)], [[0, 0], mh]],
      rectangle: [[[360, 0], r], [[0, 0], [[300, 250]]]],
      sidecontent: [[[1000, 0], [[300, 600], [300, 250]]], [[0, 0], []]]
    };
    googletag.cmd.push(function() {
    var winW = window.innerWidth || document.documentElement.clientWidth || 320;
      for (var key in AdmGpt.mappings) {
        AdmGpt.mappings[key] = AdmGpt.mappings[key].map(function(list){
          return [list[0], list[1].filter(function(size){return !Array.isArray(size) || (size[0] <= winW);})];
        });
      }
    });
  })();
  googletag.cmd.push(function() {
  var pubads = googletag.pubads();
  window.adm_gpt_slots = window.adm_gpt_slots || {};
  var adCount = 0, adxCount = 0, renderCount = 0;
  var cav = parseInt((document.cookie.match('(?:^|;) *cav=([^;]*)')||[])[1]);
  var cab = parseInt((document.cookie.match('(?:^|;) *cab=([^;]*)')||[])[1]);
  if (isNaN(cab)) {
    cab = parseInt(Math.floor(Math.random() * 5));
    document.cookie = 'cab=' + cab + '; path=/';
  }
  cav = isNaN(cav) ? 1 : cav;
  googletag.pubads().addEventListener('slotRequested', function (event) {
    adCount++;
  });
  pubads.addEventListener('slotRenderEnded', function(event) {
    var id = event.slot.getSlotElementId();
    var el = document.getElementById(id);
    if (!el) {
        console.error('Failed to find ad slot - ' + id + ' ' +  event.slot.getAdUnitPath());
        return;
    }
    if (event.advertiserId === 4411187713) {
        ++adxCount;
    }
    if (++renderCount === adCount) {
        document.cookie = 'cav=' + Math.min(4, Math.max(0, cav + (adxCount >= Math.round(renderCount * 0.5) ? 1 : -1))) + '; path=/; max-age=31536000';
    }

    el.setAttribute('data-ad-status', event.isEmpty ? 'fail' : 'done');
    // el.parentNode.style.display = event.isEmpty ? 'none' : 'block';
  });
  function setTargeting(pubads, targeting) {
    for (var k in targeting) {
      val = targeting[k];
      pubads.setTargeting(k, (val === !!val ? (val ? 'on' : 'off') : val) + '');
    }
  }
  setTargeting(pubads, {SESS_PAGE_COUNT: Math.min(window.SESS_PAGE_COUNT||0, 5), client_ad_value: cav, client_ad_bucket: cab});
  setTargeting(pubads, window.PAGE_TARGETING || {});
  setTargeting(pubads, {"section":"horoscope","page_level0":"astrology","page_level1":"horoscope","ENV":"prod"});
  AdmGpt.add('PK_Astrology_Rectangle_Middle_DFP', googletag.defineSlot('/7537783/PK_Astrology_Rectangle_Middle', [[300,250],[336,280],[728,90]], 'PK_Astrology_Rectangle_Middle_DFP').addService(pubads).defineSizeMapping(AdmGpt.mappings['all'] || []));
  AdmGpt.add('PK_Astrology_Header_DFP', googletag.defineSlot('/7537783/PK_Astrology_Header', [[320,50],[320,100],[728,90],[970,90]], 'PK_Astrology_Header_DFP').addService(pubads).defineSizeMapping(AdmGpt.mappings['header'] || []));
  AdmGpt.add('PK_Astrology_SideContent_BTF_DFP', googletag.defineSlot('/7537783/PK_Astrology_SideContent_BTF', [[300,250]], 'PK_Astrology_SideContent_BTF_DFP').addService(pubads).defineSizeMapping(AdmGpt.mappings['sidecontent'] || []));
  pubads.enableSingleRequest();
  googletag.enableServices();
gptUnits.map(function(cb){googletag.cmd.push(cb)});
});
} catch (e) {window.console && console.error && console.error("[GPTInitError] "+e);}
//]]></script>
<script async defer src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2107538958244175" crossorigin=anonymous onerror="(window.AdStatus=window.AdStatus||{}).AdsenseAsync='error'"></script>
<script>var _comscore = [{ c1: '2', c2: '9304182' }];
    loadScript$('https://sb.scorecardresearch.com/beacon.js');</script>
<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=9304182&amp;cv=2.0&amp;cj=1" width=1 height=1 alt=""></noscript>
</div>
<amp-sidebar id=site-menu class="site-menu theme-loading-hide">
<div class=site-menu-wdgt-wrapper>
<div class="wdgt-base wdgt wdgt-menu text-uppercase"><div class=wdgt-menu-heading>Astrology Links</div><ul class="wdgt-menu-list nav site-menu-nav grid-col grid-col-xs-12 grid-col-sm-6 grid-col-md-4"><li><a href="/astrology/horoscope/"><i class="icon icon-fw icon-sun-o">&#x200b;</i> Daily Horoscope</a></li><li><a href="/astrology/porutham/"><i class="icon icon-fw icon-exchange">&#x200b;</i> Kundli Matching</a></li><li><a href="/astrology/kundali-matching/"><i class="icon icon-fw icon-arrow-circle-right">&#x200b;</i> Horoscope Matching</a></li><li><a href="/astrology/panchang/"><i class="icon icon-fw icon-star">&#x200b;</i> Panchang</a></li><li><a href="/astrology/muhurat/"><i class="icon icon-fw icon-clock-o">&#x200b;</i> Muhurat Finder</a></li><li><a href="/astrology/rashifal/"><i class="icon icon-fw icon-sun-o">&#x200b;</i> Rashifal</a></li><li><a href="/astrology/sade-sati.php"><i class="icon icon-fw icon-arrow-circle-right">&#x200b;</i> Sade Sati Report</a></li><li><a href="/astrology/mangal-dosha/manglik.php"><i class="icon icon-fw icon-arrow-circle-right">&#x200b;</i> Mangal Dosha</a></li><li><a href="/astrology/birth-chart/"><i class="icon icon-fw icon-file-text-o">&#x200b;</i> Birth Chart</a></li><li><a href="/astrology/zodiac-compatibility.php"><i class="icon icon-fw icon-heart">&#x200b;</i> Zodiac Compatibility</a></li><li><a href="/astrology/nakshatra-finder/"><i class="icon icon-fw icon-star">&#x200b;</i> Nakshatra Finder</a></li><li><a href="/astrology/birthstone.php"><i class="icon icon-fw icon-diamond">&#x200b;</i> Birth Stones</a></li><li><a href="/astrology/kundli/"><i class="icon icon-fw icon-file-text-o">&#x200b;</i> Kundali</a></li><li><a href="/general/calendar"><i class="icon icon-fw icon-calendar">&#x200b;</i> Calendars</a></li><li><a href="/numerology/"><i class="icon icon-fw icon-sort-numeric-asc">&#x200b;</i> Numerology</a></li><li><a href="/astrology/planet-positions.php"><i class="icon icon-fw icon-sun-o">&#x200b;</i> Planet Positions</a></li><li><a href="/astrology/marriage.php"><i class="icon icon-fw icon-heart-o">&#x200b;</i> Marriage Prediction</a></li></ul></div>
<div class="wdgt-base wdgt wdgt-menu" data-wdgt-id=4d9a9543c93d129673e9bdec55398983></div>
</div>
</amp-sidebar>
</body>
</html>